Skip to content

Commit

Permalink
emscripten: Enable aaarch64 builds
Browse files Browse the repository at this point in the history
  • Loading branch information
hmartinez82 authored and podsvirov committed Feb 2, 2025
1 parent 47e4c73 commit 9d7bab9
Show file tree
Hide file tree
Showing 2 changed files with 23 additions and 1 deletion.
2 changes: 1 addition & 1 deletion mingw-w64-emscripten/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ _llvm_project_revision=bda19768de03a0322c4094c8d0e00ad033268309
pkgrel=1
pkgdesc="Compile C and C++ into highly-optimizable JavaScript for the web (mingw-w64)"
arch=('any')
mingw_arch=('ucrt64' 'clang64')
mingw_arch=('ucrt64' 'clang64' 'clangarm64')
url="https://emscripten.org"
msys2_repository_url="https://github.com/emscripten-core/emscripten"
license=('custom')
Expand Down
22 changes: 22 additions & 0 deletions mingw-w64-emscripten/emscripten-CLANGARM64.install
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
post_install() {
echo "You need to login again or 'source /clangarm64/etc/profile.d/emscripten.sh'"
echo "in your already running shells to be able to use emscripten."
# Install config file
WIN_PATH=$(cygpath -m /clangarm64)
rm -rf ${WIN_PATH}/lib/emscripten/.emscripten
cat > ${WIN_PATH}/lib/emscripten/.emscripten <<EOF
# .emscripten file for MSYS2 MinGW

import os
LLVM_ROOT='${WIN_PATH}/opt/emscripten-llvm/bin'
NODE_JS='${WIN_PATH}/bin/node.exe'
EOF
}

post_upgrade() {
echo "You may need to manually clear your emscripten cache as clang may not link"
echo "the new library versions with cached data properly. Use this command:"
echo "$ emcc --clear-cache"
echo "You may also need to delete ~/.emscripten if emscripten complains about old paths"
echo "or executables not found."
}

0 comments on commit 9d7bab9

Please sign in to comment.